Bug #11

Show old position

Added by Dmitry Belimov almost 9 years ago. Updated over 8 years ago.

Status:Resolved Start date:04/23/2010
Priority:High Due date:04/25/2010
Assignee:Anton Martchukov % Done:

100%

Category:-
Target version:- Estimated time:3.00 hours

Description

The page show a car on very old position. Now server can has more newest position.

Вчера тестил. Девайс точно посылает свои последние координаты, они точно приходят на сервер. Проверить как парсится, льется в сервер и выбирается в морду. Где-то косяк. Причем он похоже давно. месяц ему или полтора.


Related issues

related to Bug #12: skipping data, since data queue if full. Resolved 04/24/2010 07/10/2010

History

#1 Updated by Anton Martchukov almost 9 years ago

  • Due date set to 04/25/2010
  • Status changed from New to In Progress
  • Estimated time set to 3.00

The database thread breaks when incorrect data received from the server. This is because current server uses opengpfix libarary version without data types supports and hence no validation of the data. New opengpfix library support data types and data formatting. I will rework server to use the new library and the problem should go away.

#2 Updated by Anton Martchukov over 8 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

Duplicate of #12. Fixed.

Also available in: Atom PDF